MYUHIN Enrollment Portal
Incident Report for UHIN
Resolved
A fix has been deployed and the EDI Enrollment tool is now functional in MYUHIN. We apologize for the inconvenience.
Posted Oct 13, 2020 - 17:12 MDT
Investigating
The EDI Enrollment tool in MyUHIN is currently failing to lookup providers NPI. This affects the ability to enroll new providers. We are currently investigating the issue and will provide an update shortly.
Posted Oct 13, 2020 - 16:50 MDT
This incident affected: MYUHIN (EDI Enrollment).