SelectHealth Realtime 270/271 Outage
Incident Report for UHIN
Resolved
SelectHealth realtime 270/271 outage was resolved at approximately 10:00 am. Any failed realtime transactions should be resubmitted.
Posted Oct 19, 2020 - 15:31 MDT
Identified
SelectHealth is currently experiencing an outage with realtime 270/271 transactions. The cause of the issue has been identified and is expected to be resolved shortly.
Posted Oct 19, 2020 - 09:52 MDT
This incident affected: Clearinghouse Platform (Real Time EDI Processing).