Utah Medicaid Unscheduled Downtime
Incident Report for UHIN
Resolved
Medicaid batch and real-time transactions are now operational.
Posted Jun 13, 2019 - 17:00 MDT
Investigating
Medicaid batch and real-time transactions are currently unavailable. An update will be provided when Medicaid's systems are available.
Posted Jun 13, 2019 - 15:07 MDT
This incident affected: Clearinghouse Platform (Batch EDI Processing, Real Time EDI Processing, SFTP Connection, Payer Network).