A more connected healthcare system
Update - We are continuing to investigate this issue.
Mar 28, 2024 - 12:11 MDT
Investigating - The CHIE is investigating reports of errors with the panel upload service.
Mar 28, 2024 - 12:11 MDT
Update - New Information from Utah Medicaid regarding the Optum (Change Healthcare) pharmacy vendor network interruption:

How does this affect Utah Medicaid?
With the network and system outages, Medicaid staff have been unable to access any pharmacy claim information, including placing overrides and prior authorization information for these members. This outage is impacting Medicaid members who are attempting to fill a prescription and are not enrolled in a managed care plan or are seeking to fill a behavioral health medication.

How are pharmacies impacted?
This issue is not limited to Utah Medicaid members and providers. Optum provides technology and data to insurance companies and healthcare services nationally. They claim to handle one in three U.S. patient records. Local pharmacies are experiencing system outages, which affect people not enrolled in Medicaid, as well.

For the rest of the FAQs for members and pharmacies please see the link below:
https://medicaid.utah.gov/Documents/pdfs/FAQ_ChangeHealthcare_system_outages_2.2024.pdf

FAQs Covered
What can Utah Medicaid members do if they need a prescription filled?
What if Medicaid members have questions?
What if I’m on the Medicaid Restriction Program?
How should pharmacy providers proceed?

The last update on February 23, 2024, regarding the broader cybersecurity event impacting Change Healthcare and UHIN's response to protect your data and minimize disruption remains current.

Feb 23, 2024 - 16:54 MST
Update - We are writing to inform you of the recent cybersecurity event impacting Change Healthcare (CHC). We know this event is impacting healthcare organizations across the country and wanted to share the actions UHIN has taken in response to protect your data and minimize disruption.

Change Healthcare System Outage and UHIN's Proactive Response:

We became aware on February 22, 2024 that CHC experienced a cybersecurity incident that led them to take their systems offline. UHIN, recognizing the volume of transactions we process through CHC daily, immediately implemented a proactive approach:

Suspended all connections:
We promptly stopped all data exchange with CHC across our cloud and data center environments.

Enhanced security audits:
Our security, IT, operations, and engineering teams have conducted comprehensive audits of our systems to ensure no unauthorized access has occurred.

State-of-the-art security:
We maintain robust security measures at all times and will continue this increased level of monitoring until CHC fully resolves the incident.

Impact on Claims Processing:
We understand that this event may create delays in claims processing due to disruptions in the nationwide clearinghouse network. Our executive team is actively monitoring the situation and collaborating with industry partners to find solutions that minimize impact on your operations.

Communication and Support:
We are committed to keeping you informed and supported throughout this process. Please do not hesitate to reach out with any questions or concerns. We are available to assist you in any way we can.

Feb 23, 2024 - 09:38 MST
Identified - Change Healthcare applications are experiencing connectivity issues

Details:
Change Healthcare is experiencing a cyber security issue, and our experts are working to address the matter. At this time, the issue is believed to be specific to Change Healthcare. The disruption is expected to last at least through the day.

Additional Resources/Links:
https://status.changehealthcare.com/incidents/hqpjz25fn3n7

UHIN Action:
UHIN shut down connections to Change Healthcare at Feb 21, 2024 - 02:15 EST

If you have questions please contact our customer service team at customerservice@uhin.org, or call (877) 693-3071.

Feb 22, 2024 - 10:43 MST

About This Site

The "degraded performance" and "under maintenance" states are not considered for uptime calculations. While UHIN does track degraded performance internally (ie. slower than normal system performance) these times are not calculated by the status page.

Clearinghouse Platform Operational
90 days ago
100.0 % uptime
Today
Batch EDI Processing Operational
90 days ago
100.0 % uptime
Today
Real Time EDI Processing Operational
90 days ago
100.0 % uptime
Today
PIR Connection Operational
90 days ago
100.0 % uptime
Today
CORE Connection Operational
90 days ago
100.0 % uptime
Today
SFTP Connection Operational
90 days ago
100.0 % uptime
Today
UTRANSEND Portal Operational
90 days ago
100.0 % uptime
Today
Payer Network Operational
90 days ago
100.0 % uptime
Today
The CHIE Platform Operational
90 days ago
98.04 % uptime
Today
Alerts - Delivered via Direct Operational
90 days ago
95.77 % uptime
Today
Alerts - Delivered via SFTP Operational
90 days ago
96.92 % uptime
Today
Alerts - MYUHIN Workflow Operational
90 days ago
96.92 % uptime
Today
Clinical Portal Operational
90 days ago
99.73 % uptime
Today
Data Feeds Operational
90 days ago
100.0 % uptime
Today
Federated Query Operational
90 days ago
98.99 % uptime
Today
Results Delivery Operational
90 days ago
95.96 % uptime
Today
VPN Connectivity Operational
90 days ago
100.0 % uptime
Today
MYUHIN Operational
90 days ago
99.98 % uptime
Today
File Tool Operational
90 days ago
99.96 % uptime
Today
EDI Enrollment ? Operational
90 days ago
99.96 % uptime
Today
Eligibility Operational
90 days ago
100.0 % uptime
Today
Claims Operational
90 days ago
99.96 % uptime
Today
Claims Attachments Operational
90 days ago
100.0 % uptime
Today
Prior Authorizations Operational
90 days ago
100.0 % uptime
Today
CHIE Alerts Workflow Operational
Customer Support Operational
90 days ago
100.0 % uptime
Today
Data Source Operational
Data Source Opt Out Notifications ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Mar 29, 2024

No incidents reported today.

Mar 28, 2024
Resolved - The influx of alerts have been processed. This incident is resolved.
Mar 28, 07:43 MDT
Monitoring - The CHIE received an influx of alerts from data sources that are taking longer than normal to process. This may result in some members receiving more than normal alerts and some being slightly delayed. We are monitoring and will resolve once the backlog has all processed.
Mar 27, 14:13 MDT
Mar 27, 2024
Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024
Completed - The scheduled maintenance has been completed.
Mar 24, 15:30 MDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 23, 02:00 MDT
Scheduled - The Utah Medicaid PRISM system will be down Saturday, March 23rd, from 2:00 a.m. to Sunday, March 24th 3:30 p.m. for system maintenance.

Batch files (837, 270, 276, and 278) will be held and processed in the order they were received once Utah Medicaid is back online.

RealTime files (270 and 276) will fail during this time frame.

Please use the Eligibility LookUp Tool (ELT) for all eligibility needs at https://medicaid.utah.gov/eligibility/

Mar 20, 15:48 MDT
Mar 23, 2024
Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024
Completed - The scheduled maintenance has been completed.
Mar 20, 22:00 MDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 20, 18:00 MDT
Scheduled - The PRISM system will be down Wednesday, March 20th, from 6 p.m. to 10 p.m. for system maintenance.

· UHIN will hold files during this time frame.
· All batch files (837, 270, 276, and 278) will be processed in the order they were received once Utah Medicaid is back online.
· RealTime files (270 and 276) will fail during this timeframe.
· Please use the Eligibility LookUp Tool (ELT) for all eligibility needs at https://medicaid.utah.gov/eligibility/

Mar 12, 14:47 MDT
Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.