Medicaid has experienced delayed payments
Incident Report for UHIN
Resolved
All 835s from 5/6 have been resent.
Posted May 11, 2018 - 09:07 MDT
Update
Some 835s from Medicaid received on Sunday May, 6 2018 had incorrect check numbers. The amounts on the 835s were correct. Medicaid will be sending corrected 835s shortly.
Posted May 08, 2018 - 09:26 MDT
Identified
Medicaid payments to providers expected on 5/6/2018 are delayed.

For up to date information, please visit: https://status.uhin.org/
Posted May 07, 2018 - 16:47 MDT
This incident affected: Clearinghouse Platform (Payer Network).