Select Health Resending 277 Files
Incident Report for UHIN
Resolved
This issue was resolved in the late afternoon on 6/21/19.
Posted Jul 01, 2019 - 12:53 MDT
Monitoring
Select Health has experienced a technical difficulty resulting in the need for the resending of the 277 files this afternoon (June 21, 2019). This may result in duplication of receiving 277 files. Select Health apologizes for the inconvenience.
Transactions impacted: 277 files
Start: 6/21/19 1:46 PM
End: NA
No other additional action is required.
Posted Jun 21, 2019 - 14:40 MDT
This incident affected: Clearinghouse Platform (Real Time EDI Processing, Payer Network).