SelectHealth - Delay of 277CA Reports
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Dec 04, 2017 - 14:49 MST
Identified
SelectHealth experienced an issue which resulted in a delay to 277CA’s that are typically sent out each evening. 277CA’s can be expected to arrive in 24 hours. We apologize for the inconvenience this may cause.

For up to date information, please visit: https://status.uhin.org/
Posted Nov 29, 2017 - 08:54 MST
This incident affected: Clearinghouse Platform (Payer Network).