Medicare Part A and B is experiencing a delay in 835 delivery
Incident Report for UHIN
Resolved
The remittance advice for all Medicare Part A and B lines of business for May 11, 2018, have now delivered successfully and are available for download.
Posted May 11, 2018 - 13:27 MDT
Identified
Medicare Part A and B has experienced issues in delivering 835 reports from 5/11/2018.

For up to date information, please visit: https://status.uhin.org/
Posted May 11, 2018 - 08:56 MDT
This incident affected: Clearinghouse Platform (Payer Network).