UHIN is experiencing an intermittent outage for real time transactions.
Incident Report for UHIN
Resolved
Real time transactions are now flowing.
Posted May 17, 2018 - 10:36 MDT
Investigating
UHIN is experiencing an intermittent outage for real time transactions.

For up to date information please visit
status.uhin.org
Posted May 17, 2018 - 09:58 MDT
This incident affected: Clearinghouse Platform (Real Time EDI Processing).