Medicare Part A and B is experiencing a delay in 277CA delivery
Incident Report for UHIN
Resolved
The 277CA reports for files affected by the processing delay have delivered. Files are now processing files within normal timeframes.
Posted Dec 11, 2017 - 12:02 MST
Identified
Medicare Part A and B is currently experiencing a 277CA report delivery delay associated to 837 files submitted after approximately 9:00 am (CST) on 12/10/2017 through current.

For up to date information, please visit: https://status.uhin.org/
Posted Dec 11, 2017 - 09:38 MST
This incident affected: Clearinghouse Platform (Payer Network).