Utah Medicaid 835 Electronic Remittance Delay 11/21/2022
Incident Report for UHIN
Resolved
Resolved- all Utah Medicaid 835s delivered to customers on 11/21/22 at 1:30 PM.
Posted Nov 22, 2022 - 08:31 MST
Identified
UHIN is currently experiencing a delay with the delivery of the Utah Medicaid 835 Electronic Remittance Advice. It's expected that the issue will be resolved by 11/21/2022 at 11:30 AM.
Posted Nov 21, 2022 - 09:28 MST
This incident affected: Clearinghouse Platform (Batch EDI Processing, SFTP Connection) and MYUHIN (File Tool).