Medicare Part A is experiencing a delay in Remittance Advice delivery
Incident Report for Utah Health Information Network
Resolved
This incident has been resolved.
Posted 8 days ago. Jan 11, 2019 - 11:06 MST
Update
Medicare A & B are currently experiencing a file processing delay impacting files submitted on January 10, 2019, after 2:00 AM. Reports for these files are delayed.

For up to date information, please visit: https://status.uhin.org/
Posted 9 days ago. Jan 10, 2019 - 14:16 MST
Identified
Medicare Part A has experienced a delay in delivering for remittance advice reports for January 9, 2019.

For up to date information, please visit: https://status.uhin.org/
Posted 9 days ago. Jan 10, 2019 - 11:27 MST
This incident affected: Payer Connections.