Prior Auth & Attachments
Incident Report for UHIN
Resolved
The issue has been resolved
Posted Jun 04, 2021 - 12:48 MDT
Investigating
We are aware of an issue with Prior Auth and Attachments. The team is actively working on these issues.
Posted Jun 02, 2021 - 08:43 MDT
This incident affected: MYUHIN (Claims Attachments, Prior Authorizations).