Tricare West is experiencing a delay in 835 delivery
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jan 26, 2018 - 15:17 MST
Identified
Change Healthcare identified an interruption in normal Electronic Remittance Advice (ERA) processing and delivery. This impacts some ERA expected from the Payer for check date 11/24/2017. It results in delivery delays for the impacted ERA because the files from the Payer were not processed.

For up to date information, please visit: https://status.uhin.org/
Posted Dec 11, 2017 - 11:22 MST
This incident affected: Clearinghouse Platform (Payer Network).