Utah Medicaid Report Delivery Delay
Incident Report for UHIN
Resolved
This incident has been resolved and files are delivered. Some files may have been delivered multiple times. We apologize for any inconvenience this may have caused.
Please let us know if you have any questions or experience any issues.

Thank you
Posted Jun 20, 2019 - 14:35 MDT
Monitoring
UHIN is currently experiencing a delay in the delivery Utah Medicare reports. All reports from 6/17/2019 to current are delayed. UHIN is in the process of resolving the issue and all reports will be delivered by 6/20/2019.
Posted Jun 20, 2019 - 12:06 MDT
This incident affected: Clearinghouse Platform (Payer Network).