SelectHelath is experiencing a delay in 277CA on 8/10/2017
Incident Report for UHIN
Resolved
SelectHealth has resolved the issue with the 277CA. All of the 277CA’s for claims received after 08/07/2017 after 9:00pm MST have been sent out successfully.

We apologize for any inconvenience this may have caused.
Posted Aug 10, 2017 - 14:30 MDT
Identified
There is currently a delay in the 277CA for SelectHealth. SelectHealth is currently working on the issue.

We apologize for any inconvenience this may cause.

For up to date information, please visit: https://status.uhin.org/
Posted Aug 10, 2017 - 09:12 MDT
This incident affected: Clearinghouse Platform (Payer Network).