UHIN is investigating SFTP connection issues

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 09:54 MDT

Investigating

UHIN is investigating SFTP connection issues for some customers. Our technical teams are actively working the issue and an updates will be provided here on our status page.
Posted Aug 21, 2026 - 08:54 MDT
This incident affected: Clearinghouse Platform (SFTP Connection).