SelectHealth 835 Resends from 6/13
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Aug 13, 2024 - 11:27 MDT
Identified
SelectHealth experienced a database issue on 6/13, which caused errors with 835s.

We apologize for the inconvenience and plan to have the 835s (from 6/13) resent by 6/27.
Posted Jun 25, 2024 - 11:26 MDT
This incident affected: Clearinghouse Platform (Payer Network).