Utah Medicaid PRISM Trading Partner Agreement Update Requirement
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 15:13 MDT
Monitoring
Please be advised Utah Medicaid has provided the below notice related to PRISM Trading Partner Agreement Requirements:

All Utah Medicaid providers must have completed their Trading Partner Agreements in the PRISM enrollment steps called: Mode of Submission/EDI Exchange, Associate Billing Agent, and 835/ERA Enrollment Form. These must be completed with current submission and receipt Trading Partner Number (TPN) information to ensure claims and other HIPAA transactions are accepted into the PRISM system for processing. If these steps are not completed accurately, files will be rejected as "Entity not approved as an electronic submitter."
For verification, in PRISM, providers must check the Associate Billing Agent step for approved Trading Partner Numbers (TPN) and the associated HIPAA transaction types.
Posted Feb 28, 2023 - 16:57 MST
This incident affected: Clearinghouse Platform (Payer Network).