UHIN Transaction Delivery Delay
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 09:18 MDT
Monitoring
UHIN is currently experiencing a delay in transaction delivery. Due to today’s connectivity outage UHIN is processing a higher-than-normal volume of transaction processing. We expect all transactions will be current within 24 hours
Posted Jul 23, 2024 - 16:31 MDT
This incident affected: Clearinghouse Platform (Batch EDI Processing).