UHIN is currently experiencing Intermittent Realtime Eligibility Issues
Incident Report for UHIN
Resolved
Resolved - intermittent realtime timeouts resolved. All requests should be resent.
Posted Nov 13, 2024 - 15:43 MST
Identified
UHIN is currently experiencing intermittent 270/271 eligibility and 276/277 claims status issues. UHIN is aware of this issue and is working on a resolution.
Posted Nov 13, 2024 - 14:33 MST
This incident affected: Clearinghouse Platform (Real Time EDI Processing, PIR Connection, CORE Connection).