SelectHealth 277CA File Resent - Received Date 3/31/25 to 4/2/25

Incident Report for UHIN

Monitoring

SelectHealth has resent 277CA files with received dates of 04/01/25 and 04/02/25. Some providers may experience duplicates.

The fix for SelectHealth’s 277CA issue is currently in testing and will be deployed as soon as possible.

Again, we apologize for the inconvenience.
Posted Apr 08, 2025 - 11:39 MDT

Identified

SelectHealth is resending 277CA files with a received date of 3/31/25. Some providers may experience duplicates. We realize this causes issues for some and we sincerely apologize. Our developers are currently working on a solution that will hopefully correct the issue.
Posted Apr 07, 2025 - 16:02 MDT
This incident affects: Clearinghouse Platform (Payer Network).