Utransend is having intermittent issues.

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 15:18 MDT

Identified

Utransend is having intermittent issues. UHIN is working on a resolution.
Posted Jun 10, 2025 - 09:31 MDT
This incident affected: Clearinghouse Platform (UTRANSEND Portal).