Intermittent connectivity issues with MPI Vendor may cause delays

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 08:13 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2026 - 15:11 MDT

Investigating

We are currently experiencing intermittent connectivity issues with our MPI vendor. We are actively working with the vendor to correct the problem. Patient lookup, and alerts may be slightly delayed due to the until the issue is resolved.
Posted Aug 03, 2026 - 13:44 MDT
This incident affected: The CHIE Platform (Alerts - Delivered via Direct, Alerts - Delivered via SFTP, Alerts - MYUHIN Workflow).