Username for your MyUHIN account
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 10:44 MST
Identified
For those who received an email last week with instructions to create a MYUHIN account: We apologize if your username wasn’t clearly visible in the email. Please note that your email address is your username.
Posted Oct 28, 2024 - 14:33 MDT
This incident affected: The CHIE Platform (Clinical Portal).