MYUHIN Portal UnScheduled Downtime
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jan 25, 2024 - 13:49 MST
Identified
UHIN is currently experiencing an unscheduled downtime with MY.UHIN.ORG. We have identified the issue, and we are working to restore the connectivity.

For up to date information, please visit: https://status.uhin.org/
Posted Jan 25, 2024 - 13:01 MST
This incident affected: MYUHIN (File Tool, EDI Enrollment, Claims).