UHIN is currently experiencing Intermittent Realtime and batch webservices Issues

Incident Report for UHIN

Update

We are continuing to work on a fix for this issue.
Posted Jun 04, 2025 - 10:00 MDT

Identified

UHIN is currently experiencing intermittent eligibility and batch webservices issues. The intermittent issue started on June 2, 2025. UHIN is aware of this issue and is working on a resolution.
Posted Jun 03, 2025 - 14:22 MDT
This incident affects: Clearinghouse Platform (Real Time EDI Processing, PIR Connection, Payer Network).