CHIE timeout issues

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 08:04 MDT

Investigating

The CHIE is experiencing delays with our MPI vendor which is causing some intermittent issues with patient discovery, patient search in the portal, panel imports and possible delays in alerts. We are working with our vendor to try to resolve the issue and will post an update once resolved.
Posted Oct 14, 2025 - 14:03 MDT
This incident affected: The CHIE Platform (Alerts - Delivered via Direct, Alerts - Delivered via SFTP, Alerts - MYUHIN Workflow, Clinical Portal, Data Feeds, Federated Query, Results Delivery).