Utah Medicaid 834 Delay 1/26/2023
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jan 31, 2023 - 11:15 MST
Identified
The 834 files expected on the evenings of Tuesday, January 24th, and Wednesday, January 25th, are delayed and will be combined together and sent on the evening of Thursday, January 26th. The 834 files expected on the evening of Thursday, January 26th will be delayed and combined with the 834 files expected on the evening of Friday, January 27th.
Posted Jan 26, 2023 - 14:27 MST
This incident affected: Clearinghouse Platform (Payer Network).