SelectHealth Delay in Processing

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted Nov 27, 2023 - 14:44 MST

Update

We are continuing to investigate this issue.
Posted Nov 27, 2023 - 14:44 MST

Investigating

Today, 11/08, Select Health is experiencing a delay with the processing of the 837 transactions. As such the response 999's and TA1's may be delayed. Transactions should be caught up within the next couple of hours.

Sorry for the inconvenience.
Posted Nov 08, 2023 - 15:47 MST
This incident affected: Clearinghouse Platform (Payer Network).