UHIN Customer Support Holiday Schedule
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jan 07, 2025 - 11:45 MST
Monitoring
UHIN Customer Support Holiday Schedule

The UHIN Customer Support call center will be closed on the following days:
Tuesday, December 24th
Wednesday, December 25th
Wednesday, January 1st.

Our on-call team will actively monitor the system to ensure connectivity.

If you have an issue, please contact us through the standard support channels by emailing customersupport@uhin.org. These will be addressed in accordance with our off-hours support policies.
Posted Dec 20, 2024 - 13:14 MST
This incident affected: Customer Support.