UHIN Intermittent SFTP Connectivity Issues

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 14:47 MST

Identified

UHIN is currently experiencing an intermittent issue affecting our SFTP connections. Customers may see very brief periods when sftp.uhin.org is unavailable. If you are unable to connect, please try again. We are currently working to resolve the issue.
Posted Dec 04, 2025 - 10:55 MST
This incident affected: Clearinghouse Platform (SFTP Connection).