MYUHIN Portal Unscheduled Downtime
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 09:26 MDT
Identified
UHIN is currently experiencing an unscheduled downtime with MY.UHIN.ORG. We have identified the issue, and we are working to restore the connectivity.

For up to date information, please visit: https://status.uhin.org/
Posted Apr 17, 2024 - 08:43 MDT
This incident affected: MYUHIN (File Tool, EDI Enrollment, Eligibility, Claims).