UHIN CHIE Direct Mail Service Notice

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted May 29, 2026 - 13:56 MDT

Identified

Direct Mail may experience a brief interruption beginning at 1:00 PM MT today. Any service disruption is expected to last only a few minutes. Any messages queued during this time will be delivered once service is restored.

Thank you for your patience.
Posted May 29, 2026 - 09:40 MDT
This incident affected: The CHIE Platform (Alerts - Delivered via Direct).