UHIN Enrollment Portal is Temporarily Unavailable
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 10:26 MST
Investigating
The national NPPES NPI Registry is currently unavailable impacting the the ability of the UHIN's Enrolment Systems ability to validated provider NPI and associated information. Due to NPPES outage the UHIN Enrolment System is temporarily unavailable.
Posted Jan 06, 2021 - 10:23 MST
This incident affected: MYUHIN (EDI Enrollment) and Customer Support.