Utah Medicaid 834's for Friday 5/13 and Monday 5/16 expected to be delayed
Incident Report for UHIN
Postmortem

Verified that 271 files sent my Utah Medicaid on 5/15 delivered as expected.

Posted May 16, 2022 - 11:08 MDT

Resolved
This incident has been resolved.
Posted May 16, 2022 - 11:07 MDT
Identified
Please be advised, Utah Medicaid 834 files expected Friday, May 13th, and Monday, May 16th are expected to be delayed. They will be combined together and sent on the morning of Tuesday, May 17th. The 834 files expected on the evening of Tuesday, May 17th are expected to go out on schedule. The 834 sync files expected Sunday, May 15th are expected to go out on schedule
Posted May 10, 2022 - 16:44 MDT
This incident affected: Clearinghouse Platform (Payer Network).