Utransend portal unexpected downtime
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Feb 05, 2025 - 08:43 MST
Identified
Utransend portal unexpected downtime. UHIN has identified the issue and is working to get the portal restored.
Posted Jan 29, 2025 - 13:13 MST
This incident affected: Clearinghouse Platform (UTRANSEND Portal).