CMS announcement regarding Part A claims
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 08:55 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 06, 2023 - 08:55 MDT
Identified
Due to a CMS data center migration, the Medicare Part A Claims Processing System will be unavailable on May 22, 2023.

https://www.edissweb.com/cgp/index.html

For up to date information, please visit: https://status.uhin.org/
Posted May 18, 2023 - 11:21 MDT
This incident affected: Clearinghouse Platform (Batch EDI Processing, SFTP Connection) and MYUHIN (File Tool).