Selecthealth Maintenance 4/17/21
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Apr 23, 2021 - 13:55 MDT
Investigating
Selecthealth will perform scheduled maintenance starting on Saturday April 17th @ 3:00 pm, and may have interruptions throughout that evening. UHIN may not be able to send their 276 Realtime transactions during this period. Partners need to resend them after the maintenance has completed.
Posted Apr 13, 2021 - 16:24 MDT
This incident affected: Clearinghouse Platform (Batch EDI Processing, Real Time EDI Processing) and Customer Support.