MYUHIN is currently experiencing issues
Incident Report for UHIN
Resolved
UHIN systems are currently working as designed. Transaction processing has returned to normal service levels.
Posted May 09, 2024 - 14:36 MDT
Investigating
MYUHIN is currently experiencing issues. UHIN is aware of this issue and is investigating.
Posted May 08, 2024 - 09:35 MDT
This incident affected: MYUHIN (File Tool, EDI Enrollment, Eligibility, Claims, Claims Attachments).