UHIN Connectivity/Authentication and Transaction Delivery Outage
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 16:22 MDT
Monitoring
UHIN is currently experiencing connectivity and authentication issue that is impacting transaction delivery. Our team in researching the issue and an update will be provided shortly.
Posted Jul 23, 2024 - 09:39 MDT
This incident affected: Clearinghouse Platform (Batch EDI Processing, Real Time EDI Processing, CORE Connection, SFTP Connection, Payer Network).