UHIN Transaction Delivery Delay
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 16:49 MST
Update
We are continuing to investigate this issue.
Posted Jan 14, 2025 - 16:47 MST
Investigating
UHIN is currently experiencing a delay in transaction delivery on real-time and batch transactions.
Posted Jan 14, 2025 - 15:36 MST
This incident affected: Clearinghouse Platform (Batch EDI Processing, Real Time EDI Processing, PIR Connection, CORE Connection).