SelectHealth Resending 277ca Files with Received date of 4/18/2025

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted May 28, 2025 - 17:34 MDT

Update

We are continuing to monitor for any further issues.
Posted May 27, 2025 - 16:46 MDT

Monitoring

SelectHealth is resending 277CA files with a received date of 4/18/25. Some providers may experience duplicates. SelectHealth apologize for the inconvenience.
Posted May 27, 2025 - 16:46 MDT
This incident affected: Clearinghouse Platform (Batch EDI Processing).