Notice: CCD Queries and Document Retrieval Temporarily Down

Incident Report for UHIN

Resolved

CCD Queries and Document Retrieval capabilities have been restored and services are now functioning as expected. Thank you!
Posted Dec 23, 2025 - 10:06 MST

Investigating

CCD Queries and Document Retrieval capabilities are currently experiencing an issue. Our team is working to identify the root cause and restore functionality. We will keep you posted with updates. Thank you for your patience.
Posted Dec 22, 2025 - 11:15 MST
This incident affected: The CHIE Platform (Federated Query).