Call Center Unavailable - Major Phone Provider (Zoom) Outage

Incident Report for UHIN

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 15:13 MDT

Investigating

Due to a widespread outage with our phone provider (Zoom), the UHIN Call Center is currently unable to receive calls. In the meantime, please reach out to customersupport@uhin.org for support. We’ll update this message when service is restored.
Posted Apr 16, 2025 - 14:25 MDT
This incident affected: Customer Support.