Working to Resolve Immunization and ELR Reporting Issues

Incident Report for UHIN

Resolved

This issue has been resolved. Immunization Queries and ELR reporting to DHHS have been restored, and services are operating normally. Thank you for your patience while we worked to address this.
Posted Mar 03, 2026 - 17:01 MST

Update

We are continuing to investigate this issue.
Posted Feb 26, 2026 - 13:48 MST

Update

We are continuing to investigate this issue.
Posted Feb 26, 2026 - 13:48 MST

Investigating

We are currently experiencing issues with Immunization Queries and ELR(Electronic Lab Reporting) reporting to the State Department of Health & Human Services (DHHS). Our team is actively working with DHHS to resolve the problem. Thank you for your patience while we address this.
Posted Feb 26, 2026 - 13:46 MST
This incident affected: The CHIE Platform (Data Feeds).