MyUHIN file tool is experiencing issues.
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 09:42 MST
Investigating
MyUHIN desktop file tool is experiencing issues uploading and downloading transactions. UHIN is working on fixing this issue.
Posted Jan 14, 2025 - 16:52 MST
This incident affected: MYUHIN (File Tool).