LIFE1 Missing ERA’s and Re-enrollment
Incident Report for UHIN
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 14:39 MDT
Monitoring
PAYER ID LIFE1 may require re-enrollment. If you are currently sending to LIFE1 and have previously enrolled but stopped receiving 835s, please re-enroll through UHIN to receive your 835’s.
Posted Jul 25, 2023 - 15:59 MDT
This incident affected: Clearinghouse Platform (Batch EDI Processing) and MYUHIN (File Tool, EDI Enrollment, Claims).