UHIN phone system is down
Incident Report for UHIN
Resolved
UHIN's phone system has now been restored.
Posted Jun 22, 2017 - 09:34 MDT
Identified
UHIN's phone system is experiencing an outage. We are working on restoring them.

UHIN Community Alerts

For up to date information, please visit: https://status.uhin.org/
Posted Jun 22, 2017 - 07:56 MDT
This incident affected: Customer Support.